INSTALA METASPLOIT MEDIANTE SVN

Posted on 06/11/2011

1



Metasploit es un Framework muy potente que permite explotar vulnerabilidades y tomar control de un host, cada día se encuentran nuevas vulnerabilidades y estas son actualizadas para este Framework. Ademas tiene herramientas que nos permite desarrollar nuestros mismos Exploits. Para poder usar este Framework en su perfección, es necesario tener instalado Ruby en nuestro sistema, para lo cual lo instalaremos desde nuestros repositorios.

sudo apt-get install build-essential ruby libruby rdoc libyaml-ruby libzlib-ruby libopenssl-ruby libdl-ruby libreadline-ruby libiconv-ruby rubygems sqlite3 libsqlite3-ruby libsqlite3-dev irb subversion

Ahora bajaremos el Framework:

svn co http://metasploit.com/svn/framework3/trunk/ metasploit

Cuando termine se creara un directorio llamado metasploit.

cd metasploit

Ahora para actualizar nuestro famework, solo nos ubicamos en el directorio anterior y digitamos lo siguiente:

svn up

Para empezar a utilizar el Framework, solo digitamos lo siguiente.

sudo ./msfconsole

Anuncios
Etiquetado:
Posted in: metasploit